If your website is not working properly, you will see a white page or a 500 error message. When you use a WordPress CMS, it very often means a problem related to the script or the plugins used.
There can be many reasons, where the most common conflict occurs at the level of the plugins used, i.e. two try to perform similar operations or have not been adapted to the version of “WordPress” you are using or the PHP version you are using.
Table of Contents
Diagnostics – WP_DEBUG
The first step you should take is to activate the debugging mechanism built into WordPress . This means that by modifying a parameter in the wp-config.php file that you will find in the root directory of your website ( public_html by default), the script itself will attempt diagnostics to show you at what stage the problem appears and what may be causing it.
By default, this option is disabled and when you open the wp-config.php file for editing, you will see a parameter with the following value:
define( 'WP_DEBUG', false ); To run diagnostic mode, change the value to false, save your changes, and upload the file to the server:
define( 'WP_DEBUG', true ); Diagnostic information
Now, refresh your website in your web browser and check what types of errors appear.
If we have deprecated errors, they usually won’t cause your website to crash. They only say that some of its elements use methods that may have already been withdrawn.
Similarly, if we have messages marked as warning. Then it is also worth paying attention to them, but they are not critical errors that could immobilize your website.
Fatal error – if they appear marked in this way in the list of received messages, it is a signal that the matter should be dealt with definitively, e.g. by deactivating the plugin that is in the message description. In a situation where you do not have access to the “WordPress” panel, all you have to do is log in to FTP and there, by default, under the path domain/public_html/wp-content/plugins , you will find the directory of a given plugin and change its name, for example, by adding “1”, i.e. plugin_directory you change to plugin_directory1.
Failed update
If you are using the automatic update option or if the white page appeared after you ordered the update from the WordPress backend, log in to FTP and check if there is a .maintenance file in the root directory, i.e. domain name/public_html, which is generated by “WordPress” and is responsible for temporarily deactivating the system for the duration of the update. Once successful, WordPress automatically deletes the file. When an update error occurs, you need to delete the file manually.