In special situations, Prestashop may display error messages related to xml files. Below we present selected of them.
- Error found : Extra content at the end of the document in country_module_list.xml file
- Error found : Sequence ‘]]>’ not allowed in content in country_module_list.xml file
- Error found : internal error: detected an error in element content in country_module_list.xml file
- Error found : Extra content at the end of the document in country_module_list.xml file
- Error found : Premature end of data in tag badge line 1 in must_have_module_list.xml file
- Error found : StartTag: invalid element name in country_module_list.xml file
- Error found : Extra content at the end of the document in country_module_list.xml file
- Error found : StartTag: invalid element name in must_have_module_list.xml file
- Error found : Extra content at the end of the document in must_have_module_list.xml file
- Error found : Premature end of data in tag badges line 1 in must_have_module_list.xml file
- Error found : Premature end of data in tag module line 1 in must_have_module_list.xml file
- Error found : Premature end of data in tag modules line 1 in must_have_module_list.xml file
Table of Contents
Reason
They are due to the fact that Prestashop connects to the Addons (modules) directory every day to download several files, including this xml file for example: default_country_modules_list.xml.
If the connection is interrupted for any reason or the server does not respond or does not respond correctly, the file may be loaded incompletely, then an error occurs when trying to read and we receive an error message from the backend (store administration panel).
Solution
The solution to the problem is to log in to FTP and go to the /config/xml directory and delete the xml file causing the error, i.e. in our example default_country_modules_list.xml, in the next step it will be reloaded, usually in the correct form.
NOTE: Before deleting, we recommend that you make a copy of the file by downloading it from FTP to a directory on your local computer.
After deleting, we clean the store cache by going to Advanced – Performance – Clear cache in the backend of the store in the menu on the left and manually via FTP by going to the cache/smarty/compile directory and deleting all directories that are located there.
Workaround
If the above solution does not help, edit the tools.php file in the directory via FTP Classes
Find the code in it
protected static $is_addons_up = true;
public static function addonsRequest($request, $params = array())
{ return false;
if (!self::$is_addons_up) {
return false; and replace it with the following
protected static $is_addons_up = false;
public static function addonsRequest($request, $params = array())
{ return false;
if (!self::$is_addons_up) {
return false;